Copyrights

© Cypress Semiconductor Corporation, 2015. The information contained herein is subject to change without notice. Cypress Semiconductor Corporation assumes no responsibility for the use of any circuitry other than circuitry embodied in a Cypress product. Nor does it convey or imply any license under patent or other rights. Cypress products are not warranted nor intended to be used for medical, life support, life saving, critical control or safety applications, unless pursuant to an express written agreement with Cypress. Furthermore, Cypress does not authorize its products for use as critical components in life-support systems where a malfunction or failure may reasonably be expected to result in significant injury to the user. The inclusion of Cypress products in life-support systems application implies that the manufacturer assumes all risk of such use and in doing so indemnifies Cypress against all charges.

Any Source Code (software and/or firmware) is owned by Cypress Semiconductor Corporation (Cypress) and is protected by and subject to worldwide patent protection (United States and foreign), United States copyright laws and international treaty provisions. Cypress hereby grants to licensee a personal, non-exclusive, non-transferable license to copy, use, modify, create derivative works of, and compile the Cypress Source Code and derivative works for the sole purpose of creating custom software and or firmware in support of licensee product to be used only in conjunction with a Cypress integrated circuit as specified in the applicable agreement. Any reproduction, modification, translation, compilation, or representation of this Source Code except as specified above is prohibited without the express written permission of Cypress.

Disclaimer: CYPRESS MAKES NO WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, WITH REGARD TO THIS MATERIAL, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. Cypress reserves the right to make changes without further notice to the materials described herein. Cypress does not assume any liability arising out of the application or use of any product or circuit described herein. Cypress does not authorize its products for use as critical components in life-support systems where a malfunction or failure may reasonably be expected to result in significant injury to the user. The inclusion of Cypress’ product in a life-support systems application implies that the manufacturer assumes all risk of such use and in doing so indemnifies Cypress against all charges.

Use may be limited by and subject to the applicable Cypress software license agreement.

PSoC and CapSense are registered trademarks and PSoC Creator are trademarks of Cypress Semiconductor Corp. All other trademarks or registered trademarks referenced herein are property of the respective corporations.

Flash Code Protection

Cypress products meet the specifications contained in their particular Cypress PSoC Data Sheets. Cypress believes that its family of PSoC products is one of the most secure families of its kind on the market today, regardless of how they are used. There may be methods, unknown to Cypress, that can breach the code protection features. Any of these methods, to our knowledge, would be dishonest and possibly illegal. Neither Cypress nor any other semiconductor manufacturer can guarantee the security of their code. Code protection does not mean that we are guaranteeing the product as ‘unbreakable’.

Cypress is willing to work with the customer who is concerned about the integrity of their code. Code protection is constantly evolving. We at Cypress are committed to continuously improving the code protection features of our products.
## Contents

1.1 Kit Contents ................................................................................................................ .4
1.2 PSoC Creator ..............................................................................................................5
  1.2.1 PSoC Creator Code Examples ........................................................................6
  1.2.2 Kit Code Examples ...........................................................................................7
  1.2.3 PSoC Creator Help ..........................................................................................7
  1.2.4 Component Datasheets ...................................................................................8
1.3 Getting Started............................................................................................................. 8
1.4 Additional Learning Resources ....................................................................................8
1.5 Technical Support........................................................................................................9
1.6 Document Conventions ...............................................................................................9
2.1 Before You Begin.......................................................................................................10
2.2 Install Software ..........................................................................................................10
2.3 Uninstall Software......................................................................................................12
3.1 Theory of Operation...................................................................................................13
3.2 KitProg.......................................................................................................................14
3.3 Programming and Debugging the PSoC 5LP Target Device.....................................14
  3.3.1 Programming using PSoC Creator.................................................................14
  3.3.2 Debugging using PSoC Creator.....................................................................16
  3.3.3 Programming using PSoC Programmer.........................................................16
3.4 USB-UART Bridge .....................................................................................................17
3.5 USB-I2C Bridge .........................................................................................................17
3.6 Updating the KitProg Firmware..................................................................................17
4.1 Board Details .............................................................................................................18
4.2 Hardware Details .......................................................................................................19
  4.2.1 Target Board...................................................................................................19
  4.2.2 KitProg Board.................................................................................................20
  4.2.3 Power Supply System ....................................................................................21
  4.2.4 Board Separation (Snapping).........................................................................21
  4.2.5 Header Connections ......................................................................................22
  4.2.6 User and Passive Inputs ................................................................................25
5.1 Using the Kit Code Examples ....................................................................................28
5.2 CE95352 Blinking LED ..............................................................................................32
5.3 CE95277 ADC and UART .........................................................................................34
5.4 CE95394 USB HID Mouse ........................................................................................35
PSoC 5LP Prototyping Kit Schematics ...............................................................................36
Programming PSoC 5LP Prototyping Kit Using MiniProg3/KitProg ....................................38
Bill of Materials .............................................................................................................39
Regulatory Compliance

The CY8CKIT-059 PSoC 5LP Prototyping Kit is intended for use as a development platform for hardware or software in a laboratory environment. The board is an open system design, which does not include a shielded enclosure. This may cause interference to other electrical or electronic devices in close proximity. In a domestic environment, this product may cause radio interference. In such cases, you may be required to take adequate preventive measures. In addition, this board should not be used near any medical equipment or RF devices.

Attaching additional wiring to this product or modifying the product operation from the factory default may affect its performance and cause interference with other apparatus in the immediate vicinity. If such interference is detected, suitable mitigating measures should be taken.

The PSoC 5LP Prototyping Kit, as shipped from the factory, has been verified to meet with requirements of CE as a Class A product.

The PSoC 5LP Prototyping Kit contains electrostatic discharge (ESD) sensitive devices. Electrostatic charges readily accumulate on the human body and any equipment, and can discharge without detection. Permanent damage may occur on devices subjected to high-energy discharges. Proper ESD precautions are recommended to avoid performance degradation or loss of functionality. Store unused PSoC 5LP Prototyping Kit boards in the protective shipping package.

End-of-Life/Product Recycling

This kit has an end-of-life five years from the date of manufacture mentioned on the back of the box. Contact your nearest recycler for discarding the kit.
Safety Information

General Safety Instructions

ESD Protection
ESD can damage boards and associated components. Cypress recommends that you perform procedures only at an ESD workstation. If such a workstation is not available, use appropriate ESD protection by wearing an antistatic wrist strap attached to the chassis ground (any unpainted metal surface) on your board when handling parts.

Handling Boards
PSoC 5LP Prototyping Kit boards are sensitive to ESD. Hold the board only by its edges. After removing the board from its box, place it on a grounded, static-free surface. Use a conductive foam pad if available. Do not slide board over any surface.
1. Introduction

Thank you for your interest in the CY8CKIT-059 PSoC 5LP Prototyping Kit. The PSoC 5LP prototyping kit is designed as an easy-to-use and inexpensive prototyping platform. The PSoC 5LP Prototyping Kit supports the PSoC 5LP device family, delivering a complete system solution for a wide range of embedded applications at a very low cost. The PSoC 5LP is the industry’s most integrated SoC with an ARM® Cortex™-M3 CPU. It combines programmable and reconfigurable high-precision analog and digital blocks with flexible automatic routing. The unique flexibility of the PSoC 5LP architecture will be helpful for those who want to rapidly develop products using the PSoC 5LP device family.

The PSoC 5LP Prototyping Kit offers an open footprint breakout board to maximize the end-utility of the PSoC 5LP device. This kit provides a low-cost alternative to device samples while providing a platform to easily develop and integrate the PSoC 5LP device into your end-system. In addition, the board includes the following features:

- Micro-USB connector to enable USB application development
- On-board CMOD capacitors to enable CapSense® development
- Bypass capacitors to ensure the high-quality ADC conversions
- An LED to provide feedback
- A push button to provide a simple user input
- Load capacitors to connect 32 kHz external crystal oscillator
- 3.3V to 5.5V operation

The PSoC 5LP prototyping kit also integrates the Cypress KitProg that enables on-board programming, debugging and bridging functionality, such as USB-UART and USB-I2C. The KitProg is used to program and debug the target PSoC 5LP device (see Figure 1-1). The prototyping kit allows you to separate the KitProg board from the PSoC 5LP target board.

1.1 Kit Contents

This kit contains only the PSoC 5LP Prototyping Kit board.

Figure 1-1. CY8CKIT-059 PSoC 5LP Prototyping Kit
1.2 PSoC Creator

PSoC Creator™ is a state-of-the-art, easy-to-use integrated design environment (IDE). It introduces revolutionary hardware and software co-design, powered by a library of pre-verified and pre-characterized PSoC Components. With PSoC Creator, you can:

1. Drag and drop Components to build your hardware system design in the main design workspace
2. Codesign your application firmware with the PSoC hardware
3. Configure Components using configuration tools
4. Explore the library of 100+ Components
5. Review Component datasheets

Figure 1-2. PSoC Creator Features

PSoC Creator also enables you to tap into an entire tool ecosystem with integrated compiler chains and production programming programmers for PSoC devices.

For more information, visit www.cypress.com/psoccreator.
1.2.1 PSoC Creator Code Examples

PSoC Creator includes a large number of code examples. These examples are available from the PSoC Creator Start Page, as Figure 1-3 on page 6 shows.

Code examples can speed up your design process by starting you off with a complete design, instead of a blank page. The code examples also show how PSoC Creator Components can be used for various applications. Code examples and documentation are included, as shown in Figure 1-4 on page 7.

In the Find Example Project dialog shown in Figure 1-4, you have several options:

- Filter for examples based on architecture or device family, that is, PSoC 3, PSoC 4 or PSoC 5LP; project name; or keyword
- Select from the menu of examples offered based on the Filter Options
- Review the example project's description (on the Documentation tab)
- Review the code from the Sample Code tab. You can copy the code from this window and paste to your project, which can help speed up code development
- Create a new project (and a new workspace if needed) based on the selection. This can speed up your design process by starting you off with a complete, basic design. You can then adapt that design to your application.

Figure 1-3. Code Examples in PSoC Creator
1.2.2 Kit Code Examples

This kit includes a number of code examples which can be used to quickly evaluate the functionality of this kit. These examples are described in the Code Examples.

1.2.3 PSoC Creator Help

Visit the PSoC Creator home page to download the latest version of PSoC Creator. Then, launch PSoC Creator and navigate to the following items:

- **Quick Start Guide**: Choose Help > Documentation > Quick Start Guide. This guide gives you the basics for developing PSoC Creator projects.

- **Simple Component example projects**: Choose File > Open > Example projects. These example projects demonstrate how to configure and use PSoC Creator Components.

- **Starter designs**: Choose File > New > Project > PSoC 5LP Starter Designs. These starter designs demonstrate the unique features of PSoC 5LP.

- **System Reference Guide**: Choose Help > System Reference > System Reference Guide. This guide lists and describes the system functions provided by PSoC Creator.

- **Component datasheets**: Right-click a Component and select Open Datasheet, as shown in Figure 1-5 on page 8. Visit the PSoC 5LP Component Datasheets page for a list of all PSoC 5LP Component datasheets.

- **Document Manager**: PSoC Creator provides a document manager to help you to easily find and review document resources. To open the document manager, choose the menu item Help > Document Manager.
1.2.4 Component Datasheets
Right-click a Component and select Open Datasheet (see Figure 1-5 on page 8).

Figure 1-5. Opening Component Datasheet

1.3 Getting Started
This guide will help you get acquainted with the PSoC 5LP Prototyping Kit:

- The Software Installation chapter on page 10 describes the installation of the kit software. This includes installation of PSoC Creator IDE for development and debugging the applications, and PSoC Programmer for programming hex files.
- The Kit Operation chapter on page 13 describes the major features of the PSoC 5LP Pioneer Kit and functionalities such as programming, debugging, and the USB-UART and USB-I2C bridges.
- The Hardware chapter on page 17 details the hardware content of the kit and the hardware operation.
- The Code Examples chapter on page 27 describes multiple PSoC 5LP code examples that will help you understand how to create your own PSoC 5LP projects.
- The Appendix chapter on page 35 provides schematics, details about programming the kit using Miniprog, and the bill of materials (BOM).

1.4 Additional Learning Resources
Cypress provides a wealth of information at www.cypress.com to help you to select the right PSoC device for your design, and to help you to quickly and effectively integrate the device into your design. For a comprehensive list of resources, see KBA86521, How to Design with PSoC 3, PSoC 4, and PSoC 5LP. The following is an abbreviated list for PSoC 5LP:

- Overview: PSoC Portfolio, PSoC Roadmap
- Product Selectors: PSoC 1, PSoC 3, PSoC 4, or PSoC 5LP. In addition, PSoC Creator includes a device selection tool.
- Datasheets: Describe and provide electrical specifications for the PSoC 5LP device family
- CapSense Design Guide: Learn how to design capacitive touch-sensing applications with the PSoC 5LP family of devices.
- Application Notes and Code Examples: Cover a broad range of topics, from basic to advanced level. Many of the application notes include code examples. Visit the PSoC 3/4/5 Code Examples webpage for a list of all available PSoC Creator code examples. For accessing code examples from within PSoC Creator - see PSoC Creator Code Examples.
Introduction

- **Technical Reference Manuals (TRM):** Provide detailed descriptions of the architecture and registers in each PSoC 5LP device family.

- **Development Kits:**
  - CY8CKIT-050 PSoC 5LP Development Kit enables you to evaluate, develop, and prototype high-precision analog, low-power, and low-voltage applications designed using the PSoC 5LP device family.
  - CY8CKIT-001 is a common development platform for all PSoC family devices.
  - PSoC 5LP Expansion Boards are the expansion modules designed to implement a target application.

- The MiniProg3 device provides an interface for flash programming and debug.

- **Knowledge Base Articles (KBA):** Provide design and application tips from experts on using the device.

- **PSoC Creator Training:** Visit the link www.cypress.com/go/creatorstart/creatortraining for a comprehensive list of video trainings on PSoC Creator.

- **Learning From Peers:** Visit www.cypress.com/forums to meet enthusiastic PSoC developers discussing the next generation embedded systems on Cypress Developer Community Forums.

1.5 Technical Support

If you have any questions, our technical support team is happy to assist you. You can create a support request on the Cypress Technical Support page.

If you are in the United States, you can talk to our technical support team by calling our toll-free number: +1-800-541-4736. Select option 8 at the prompt.

You can also use the following support resources if you need quick assistance.

- **Self-help**
- **Local Sales Office Locations**

1.6 Document Conventions

<table>
<thead>
<tr>
<th>Convention</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Courier New</td>
<td>Displays file locations, user entered text, and source code: C:...cd\icc\</td>
</tr>
<tr>
<td><strong>Italics</strong></td>
<td>Displays file names and reference documentation: Read about the sourcefile.hex file in the PSoC Creator User Guide.</td>
</tr>
<tr>
<td><strong>Bracketed, Bold</strong></td>
<td>Displays keyboard commands in procedures: [Enter] or [Ctrl] [C]</td>
</tr>
<tr>
<td>File &gt; Open</td>
<td>Represents menu paths: File &gt; Open &gt; New Project</td>
</tr>
<tr>
<td><strong>Bold</strong></td>
<td>Displays commands, menu paths, and icon names in procedures: Click the File icon and then click Open.</td>
</tr>
<tr>
<td>Times New Roman</td>
<td>Displays an equation: ( 2 + 2 = 4 )</td>
</tr>
<tr>
<td><strong>Text in gray boxes</strong></td>
<td>Describes Cautions or unique functionality of the product.</td>
</tr>
</tbody>
</table>
2. Software Installation

This chapter describes the steps to install the software tools and packages on a PC for using the PSoC 5LP Prototyping Kit. This includes the IDE on which the projects will be built and used for programming.

2.1 Before You Begin

All Cypress software installations require administrator privileges, but these are not required to run the software after it is installed. Close any other Cypress software that is currently running before installing the kit software.

Note: By default, the kit contents are installed in the C:\Program Files\Cypress folder, for a 32-bit machine and C:\Program Files (x86)\Cypress, for a 64-bit machine. This directory will contain the kit example projects. In order to open these examples, it is recommended to use the procedure as described in the Code Examples chapter. That procedure will create an editable copy of the example in a path that you chose so that the original installed examples will not be modified.

2.2 Install Software

Follow these steps to install the PSoC 5LP Prototyping Kit software:

1. Download the PSoC 5LP Prototyping Kit software from http://www.cypress.com/CY8CKIT-059. The kit software is available in three formats for download.
   a. CY8CKIT-059 Kit Setup: This installation package contains the files related to the kit including PSoC Creator and PSoC Programmer. However, it does not include the Windows Installer or Microsoft .NET framework packages. If these packages are not on your computer, the installer directs you to download and install them from the Internet.
   b. CY8CKIT-059 Kit Only: This executable file installs only the kit contents, which include kit code examples, hardware files, and user documents. This package can be used if all the software prerequisites (listed in step 5) are installed on your PC.
   c. CY8CKIT-059 DVD ISO: This file is a complete package, stored in a DVD-ROM image format, that you can use to create a DVD or extract using an ISO extraction program such as WinZip or WinRAR. The file can also be mounted like a virtual CD/DVD using virtual drive programs such as Virtual CloneDrive and MagicISO. This file includes all the required software, utilities, drivers, hardware files, and user documents.

2. If you have downloaded the ISO file, mount it in a virtual drive. Extract the ISO contents if you do not have a virtual drive to mount. Double-click cyautorun.exe in the root directory of the extracted content or mounted ISO if "Autorun from CD/DVD" is not enabled on the PC. The installation window will appear automatically. Note: If you are using the "Kit Setup" or "Kit Only" file, then go to step 4 for installation.
3. Click **Install CY8CKIT-059 Kit** to start the kit installation, as shown in **Figure 2-1**.

![Kit Installer Screen](image)

**Figure 2-1. Kit Installer Screen**

4. Select the directory in which you want to install the PSoC 5LP Prototyping Kit-related files. Choose the directory and click **Next**.

5. When you click **Next**, the PSoC 5LP Prototyping Kit installer automatically installs the required software, if it is not present on your computer. Following is the required software:
   a. PSoC Creator 3.1 or later: This software is also available separate from the kit at [www.cypress.com/psoccreator](http://www.cypress.com/psoccreator).
   b. PSoC Programmer 3.22.2 or later: This is installed as part of PSoC Creator installation ([www.cypress.com/programmer](http://www.cypress.com/programmer)).

6. Choose the **Typical/Custom/Complete** installation type in the Product Installation Overview window, as shown in **Figure 2-2**. Click **Next** after you select the installation type.
7. Read the License agreement and select 'I accept the terms in the license agreement' to continue with installation. Click on Next.

8. When the installation begins, a list of packages appears on the installation page. A green check mark appears next to each package after successful installation.

9. Enter your contact information or select the check box Continue Without Contact Information. Click Finish to complete the PSoC 5LP Prototyping Kit installation.

10. After the installation is complete, the kit contents are available at the following location: 
<Install_Directory>\CY8CKIT-059

Default location:
Windows OS (64-bit):
C:\Program Files (x86)\Cypress\CY8CKIT-059

Windows OS (32-bit):
C:\Program Files\Cypress\CY8CKIT-059

Note: For Windows 7/8/8.1 users, the installed files and the folder are read only. To use the installer code examples, follow the steps outlined in the Code Examples chapter.

2.3 Uninstall Software

The software can be uninstalled using one of the following methods:

1. Go to Start > All Programs > Cypress > Cypress Update Manager and select the Uninstall button.

2. Go to Start > Control Panel > Programs and Features for Windows 7 or Add/Remove Programs for Windows XP; select the Uninstall/Change button.
3. Kit Operation

This chapter introduces you to the different features of the PSoC 5LP Prototyping Kit. This primarily includes the programming/debugging functionality, KitProg USB-UART and USB-I2C bridges, and the method to update the KitProg firmware.

3.1 Theory of Operation

Figure 3-1 shows the block diagram for the PSoC 5LP Prototyping Kit.

![Figure 3-1. Block Diagram of PSoC 5LP Prototyping Kit](image)

The PSoC 5LP Prototyping Kit is simplistic in design and focuses on providing you with complete access to develop applications using the PSoC 5LP device family. This kit supports the following features:

- **KitProg**: It is an on-board programmer/debugger, which enables the user to program and debug the target PSoC 5LP device. It can also act as a USB-UART and UART-I2C bridge. When used as a standalone module, it can be used to program devices of PSoC 3, PSoC 4, or PSoC 5 families through the SWD interface. For more details on the KitProg functionality, refer to the KitProg User Guide in the kit installation directory: `<Install_Directory>\CY8CKIT-059\<version>\Documentation\KitProg_User_Guide.pdf`.

- **Expansion Headers**: The PSoC 5LP Prototyping Kit brings all I/Os of the device to the two expansion headers, enabling the user to have maximum access to the capabilities of PSoC 5LP device.

- **Micro-USB Connector**: The on-board micro-USB connector provides access to the USB block of PSoC 5LP device. This connector enables the user to develop USB applications.

- **User LED**: The on-board LED can be used to display outputs from the PSoC 5LP device. This includes modulating the brightness of the LED to notify different states of the device.
Kit Operation

- Push Button (SW): This kit has a push button, which can be used to provide input to the PSoC 5LP.

**Note:** The switch connects the PSoC 5LP pin to ground when pressed. Therefore, you need to configure the PSoC 5LP pin as resistive pull-up for detecting the switch press.

- Reset Button: This button is used for the following purposes:
  - Reset the PSoC 5LP device: When pressed, it connects the XRES line of the PSoC 5LP to ground and resets the PSoC 5LP device.
  - Bootload the KitProg: When pressed while connecting the kit’s PCB USB connector to the USB port of the PC, this button puts the KitProg into the bootloader mode. For more details on the KitProg functionality, refer to the KitProg User Guide.

**Note:** When the two boards are separated, the user can mount the SW2 button on the target board to reset the PSoC 5LP device using a switch.

### 3.2 KitProg

The KitProg is a multi-functional system, which includes a programmer, debugger, USB-I2C bridge, and a USB-UART bridge. The Cypress PSoC 5LP device is used to implement KitProg functionality. The KitProg is integrated in most PSoC development kits. For more details on the KitProg functionality, refer to the KitProg User Guide in the kit installation directory: `<Install_Directory>\CY8CKIT-059\<version>\Documentation\KitProg_User_Guide.pdf`.

### 3.3 Programming and Debugging the PSoC 5LP Target Device

The target PSoC 5LP device can be programmed and debugged using the KitProg. Before programming the device, ensure that PSoC Creator and PSoC Programmer software are installed on the PC. See Install Software on page 10 for more information.

#### 3.3.1 Programming using PSoC Creator

1. Connect the kit to the computer through the PCB USB connector, J10, as shown in Figure 3-2. The kit will enumerate as a composite device, if you are plugging in the PSoC 5LP Prototyping Kit to your PC for the first time.

**Figure 3-2. Connecting the PSoC 5LP Prototyping Kit to a Computer**
2. Open the desired project in PSoC Creator. For this, go to File > Open > Project/Workspace. This provides the option to browse to and open a previously saved project. If you want to open one of the example projects provided with the kit, follow the instructions in the Code Examples chapter.

3. Select the option Build > Build Project or press [Shift] [F6] to build the project as shown in Figure 3-3.

Figure 3-3. Build an Example Project

4. If there are no errors during build, program the firmware into the kit by choosing Debug > Program or press [Ctrl] [F5], as shown in Figure 3-4. This programs the target PSoC 5LP device on the PSoC 5LP Prototyping Kit, and the kit is ready to use.

Figure 3-4. Programming Device From PSoC Creator
3.3.2 Debugging using PSoC Creator

For debugging the project using PSoC Creator, follow steps 1-4 from Programming using PSoC Creator on page 14 followed by:

1. Click on the Debug icon or press [F5]. Alternatively, you can use the option Debug > Debug.
2. Once the PSoC Creator opens in Debug mode, use the buttons on the toolbar to debug your application.

For more details on using the debug features, refer to section 3.2 of the KitProg User Guide.

3.3.3 Programming using PSoC Programmer

PSoC Programmer (3.22.2 or later) can be used to program existing .hex files into the PSoC 5LP Prototyping Kit. Refer to section 3.3 of the KitProg User Guide for a detailed explanation on how to program using PSoC Programmer.

3.4 USB-UART Bridge

The KitProg on the PSoC 5LP Pioneer Kit can act as a USB-UART bridge. The UART lines between the KitProg and the target are hard-wired on the board, through the snappable area, with UART_RX assigned to P12_6 and UART_TX assigned to P12_7 on PSoC 5LP (target). For more details on the KitProg USB-UART functionality, refer to the KitProg User Guide.

3.5 USB-I2C Bridge

The KitProg can function as a USB-I2C bridge and communicate with the software utility, Bridge Control Panel (BCP). The I2C lines on PSoC 5LP (target) device are P12_1 (SDA) and P12_0 (SCL), which are hardwired on the board to the I2C lines of the KitProg. The USB-I2C supports I2C speeds of 50 kHz, 100 kHz, 400 kHz, and 1 MHz. For more details on the KitProg USB-I2C functionality, refer to the KitProg User Guide.

3.6 Updating the KitProg Firmware

The KitProg firmware normally does not require any update. You can use the PSoC Programmer software to update the KitProg firmware. Refer to the KitProg Use Guide for a detailed explanation on how to update the KitProg firmware.
4. Hardware

4.1 Board Details

The PSoC 5LP Prototyping Kit consists of the following blocks:
- PSoC 5LP device
- PSoC 5LP header ports J1 and J2
- Micro-USB Connector, J6
- PSoC 5LP Program/Debug JTAG header, J5
- KitProg (PSoC 5LP) device
- KitProg ports J8 and J9 (GPIO)
- SWD connection J3 and J7
- PCB USB connector
- One amber LED (Power)
- One green LED (Status)
- One blue LED (User)
- User Push Button and Reset Button
- External reference capacitors (ADC Bypass)
- CapSense capacitor (CMOD)
- Programming connector, J3
- Perforated ‘snappable’ board design

Figure 4-1. PSoC 5LP Prototyping Kit Pin Details
4.2 Hardware Details

4.2.1 Target Board

The target board uses the PSoC 5LP family device. PSoC 5LP is the industry's most integrated programmable SoC, integrating high-precision and programmable analog and digital peripherals, and an ARM® Cortex™-M3 CPU. The PSoC 5LP features a high-precision analog-to-digital converter (ADC), programmable amplifiers, flexible digital subsystem, unmatched parallel co-processing digital filter block (DFB), high-throughput peripherals such as DMA, CAN, and USB, and standard communication and timing peripherals. The programmable analog and digital subsystems allow flexibility and in-field tuning of the design. For more information, refer to the PSoC 5LP family datasheet in the PSoC 5LP web page.

Figure 4-2. Schematic of PSoC 5LP (Target)
4.2.2 KitProg Board

PSoc 5LP on the KitProg board is used to program and debug the target PSoC 5LP device. The KitProg PSoC 5LP connects to the USB port of the PC through the PCB USB connector and to the SWD interface of the target PSoC 5LP device.

Figure 4-3. Schematic of PSoC 5LP (KitProg)
4.2.3 Power Supply System

The power supply system on this board is dependent on the source of the power. For most applications, you can use the 5 V supply from the USB connection to power the system. You can also connect an external power supply to the board for low-voltage applications. The kit supports the following connections:

- 5 V from the KitProg USB
- 5 V from the PSoC 5LP Target USB (this will not power the KitProg section of the board)
- 3.3V to 5.5V from a regulated supply connected to VDD (this will not power the KitProg section of the board)

Note: In order to use an external power supply, while KitProg is connected to the PCB USB, remove diode, D1, from the board. This ensures that VTARG supply from KitProg is not supplied to the target device. KitProg measures the target voltage and adjusts the logic levels on the programming pins accordingly.

It is important to understand that this prototyping kit does not have any onboard ESD protection circuitry. Therefore, the power source for the PSoC 5LP Prototyping Kit must be of a high quality to ensure that the board is protected from any over-current conditions and swapped-power connections.

4.2.3.1 Measure PSoC 5LP Current Consumption

You can measure the current consumption of the PSoC 5LP device by using one of these methods:

Method 1:
1. Separate the KitProg board by 'snapping' the perforated edge between the two boards.
2. Power the remaining prototyping board via any of the VDD or VTARG terminals.
3. Place an ammeter in series with the VDD or VTARG connection to measure the current consumption.

Method 2:
1. Remove the resistor R20 and install a 2-pin jumper in the supplied holes of J4.
2. Connect an ammeter across the 2-pin jumper to measure the current to the PSoC 5LP device.

This method can be used either with USB power or with power supplied to one of the VTARG pins but NOT when supplying to one of the VDD pins.

4.2.4 Board Separation (Snapping)

The PSoC 5LP Prototyping Kit consists of both a PSoC 5LP and a KitProg board. To separate the two boards for testing or development, break the two boards apart at the built-in perforated edge.

The easiest method of separating the two boards is to place the kit on the edge of a table, where the edge of the table is directly below the perforated edge and the smaller KitProg board is off the table edge. Press gently on the KitProg board and snap the two boards apart. If any material is removed from the edge of the boards, use sheers to clean up the edge of the kit.
4.2.5 Header Connections

The PSoC 5LP Prototyping Kit supports a number of unpopulated headers on both the KitProg and the target PSoC 5LP boards.

4.2.5.1 Functionality of the J1 and J2 Headers (Target Board)

The target board contains two dual-inline headers (J1 and J2). These headers are both 1×26-pin headers and include all of the I/O available on the PSoC 5LP device. These headers support all of the available ports, GND, VDD, and connections to passive elements and user-input devices.

The J1 and J2 headers support 100-mil spacing, so you can solder connectors to connect the target board to any development breadboard.

Figure 4-5. J1 and J2 Headers
4.2.5.2 Functionality of J7 and J3 Headers (PSoC 5LP to KitProg)

The KitProg and target boards each contain a 1x5-pin header. These headers provide a physical connection between the two devices. Specifically, the connection includes the SWD interface, required to program/debug the target PSoC 5LP device, power, ground, and reset.

Figure 4-6. J7 and J3 Headers
When the boards are separated, the KitProg board can be used to program any other PSoC 3, PSoC 4, or PSoC 5LP family of devices via J7.

### 4.2.5.3 Functionality of J8 and J9 Headers (KitProg)

The KitProg board contains two dual-inline headers (J8 and J9). These headers are both 1x7-pin-headers, used to pull out several pins of PSoC 5LP to support advanced features like a low-speed oscilloscope and a low-speed digital logic analyzer. This header also contains the KitProg bridge pins that can be used when the two boards are separated.

The J8 and J9 headers support 100-mil spacing, so you can solder connectors to connect the KitProg board to any development breadboard.

**Figure 4-7. J8 and J9 Headers**

<table>
<thead>
<tr>
<th>PSoC 5LP to KitProg Header (J7)</th>
<th>PSoC 5LP Prototyping Kit GPIO Header (J3)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pin</td>
<td>Signal</td>
</tr>
<tr>
<td>J7_01</td>
<td>VDD</td>
</tr>
<tr>
<td>J7_02</td>
<td>GND</td>
</tr>
<tr>
<td>J7_03</td>
<td>P12.4</td>
</tr>
<tr>
<td>J7_04</td>
<td>P12.3</td>
</tr>
<tr>
<td>J7_05</td>
<td>P12.2</td>
</tr>
</tbody>
</table>

When the boards are separated, the KitProg board can be used to program any other PSoC 3, PSoC 4, or PSoC 5LP family of devices via J7.

### 4.2.5.3 Functionality of J8 and J9 Headers (KitProg)

The KitProg board contains two dual-inline headers (J8 and J9). These headers are both 1x7-pin-headers, used to pull out several pins of PSoC 5LP to support advanced features like a low-speed oscilloscope and a low-speed digital logic analyzer. This header also contains the KitProg bridge pins that can be used when the two boards are separated.

The J8 and J9 headers support 100-mil spacing, so you can solder connectors to connect the KitProg board to any development breadboard.

**Figure 4-7. J8 and J9 Headers**

<table>
<thead>
<tr>
<th>PSoC 5LP to KitProg Header (J9)</th>
<th>PSoC 5LP Prototyping Kit Header (J8)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pin</td>
<td>Signal</td>
</tr>
<tr>
<td>J9_01</td>
<td>VDD</td>
</tr>
<tr>
<td>J9_02</td>
<td>GND</td>
</tr>
<tr>
<td>J9_03</td>
<td>P12.5</td>
</tr>
<tr>
<td>J9_04</td>
<td>P12.0</td>
</tr>
<tr>
<td>J9_05</td>
<td>P12.1</td>
</tr>
<tr>
<td>J9_06</td>
<td>P12.6</td>
</tr>
<tr>
<td>J9_07</td>
<td>P12.7</td>
</tr>
</tbody>
</table>
4.2.6 User and Passive Inputs

4.2.6.1 Push Button

The target PSoc 5LP board contains a single push button connected to the P2.2 pin on the
PSoc 5LP device. This button can be used for general user inputs or to control different states in an
application.

Figure 4-8. Push Button on the Board

4.2.6.2 Reset/Boot Button

The KitProg board contains a push button connected to the XRES pin on the target PSoc 5LP
device and P12_4 of the KitProg device. This button serves two functions:

- Reset the PSoc 5LP device: When this button is pressed, XRES line of the PSoc 5LP is
  connected to ground, which, in turn, resets the target device.

- Bootload the KitProg: When this button is pressed while plugging the KitProg into the USB port of
  the PC, the KitProg enters the bootloader mode. In this mode, bootloadable applications can be
  downloaded on the KitProg device.

Figure 4-9. Reset/Boot Button

Reset Button

The target board also provides a foot-print for a through-hole switch which can be used to reset the
device when the two boards are separated.

Figure 4-10. Reset (RST) Button
4.2.6.3 LEDs

The PSoC 5LP Prototyping Kit contains three LEDs:

- The amber LED: Indicates that the board is powered from the PCB USB connector. This LED will not light when the board is powered from the micro USB connector or from VDD or VTARG directly.
- The green LED: Indicates the KitProg status, connected to P3.1 of the KitProg PSoC 5LP device. For more details on the KitProg status LED, refer to the KitProg User Guide.
- The blue LED: This is the user LED, connected to P2.1 of the target PSoC 5LP device.

Figure 4-11. Power LED

Figure 4-12. Status LED

Figure 4-13. User LED
4.2.6.4 System Capacitors

There are seven capacitors on the PSoC 5LP Prototyping Kit, used when ADC operation at high frequencies, CapSense or external 32kHz crystal oscillator is required in the application.

- Four ADC bypass capacitors: Required for proper ADC sampling at higher frequencies:
  - C9 and C12 - For two SAR ADCs
  - C7 and C13 - For Delta Sigma ADC
- A CapSense capacitor (CMOD): Required for proper CapSense functionality.
- Two biasing capacitors: Required for interfacing an external 32kHz crystal oscillator. These capacitors are added in the Rev *A version of the PSoC 5LP Prototyping Kit.

Note: Crystal oscillator is not placed on the board, it can be soldered on pins P15_2 and P15_3.

Figure 4-14. System Capacitors Circuit Diagram
5. Code Examples

This chapter explains the code examples provided along with the PSoC 5LP Prototyping Kit. To access these code examples, download and install the CY8CKIT-059 PSoC 5LP Prototyping Kit setup file from the kit web page: www.cypress.com/CY8CKIT-059. After installation, the code examples will be available in the Firmware folder in the installation location.

5.1 Using the Kit Code Examples

Follow these steps to open and use the example projects.

1. Launch PSoC Creator from the Windows Start menu (Start > All Programs > Cypress > PSoC Creator<version> > PSoC Creator<version>).
2. On the Start page, click on CY8CKIT-059 under Examples and Kits > Kits. A list of example projects appears, as shown in Figure 5-1.
3. Click on the desired example project and save it at a desired location. For the remaining steps, CE95277 ADC and UART.cywrk is used as reference.

Figure 5-1. Open Example Project from PSoC Creator
4. Build the example project by choosing **Build > Build <Project Name>**, as shown in Figure 5-2. A .hex file is generated after the build process.

**Figure 5-2. Open Example Project from PSoC Creator**

5. Connect the PSoC 5LP Prototyping Kit to the PC using the KitProg PCB USB port, J10 as described in PSoC 5LP Prototyping Kit USB Connection to program the kit with this code example.

6. Choose **Debug > Program** in PSoC Creator as shown in Figure 5-3.

**Figure 5-3. Program Device in PSoC Creator**
7. PSoC Creator opens the programming window if the device is not yet acquired. Select KitProg and click the Port Acquire button, as shown in Figure 5-4.

Figure 5-4. Port Acquire

8. After the device is acquired, it is shown in a tree structure below the KitProg. Click the Connect button and then OK to exit the window and start programming, as shown in Figure 5-5.

Figure 5-5. Connect Device From PSoC Creator and Program
9. From the workspace explorer in PSoC Creator, open the *CE95277 ADC and UART.pdf* as shown in Figure 5-6.

Figure 5-6. Project Datasheet - CE95277 ADC and UART.pdf
5.2 CE95352 Blinking LED

This example demonstrates use of a fixed function PWM. The PWM is set up to output a 50% duty cycle digital signal with a period of 1 second. This signal can be used to drive an LED for visual testing of the PWM output. A switch is routed into the kill input of the PWM. When the switch is pressed the PWM output is shut off.

Figure 5-7. TopDesign for CE95352 Blinking LED

PWM Settings:
- Fixed Function
- 8 bit
- Single Output
- Period = 100 counts, 1 sec
- Compare = 50 counts, Greater than

Test Setup and Procedure:
1) Plug CY8CKIT-059 into USB port of PC.
2) Program the board and observe the blue LED blinking at a rate of 1 Hz.
3) Press and hold SW1 on the kit to stop the PWM output and observe the LED no longer blinking. Release the button to enable the PWM output.

For a detailed description, refer to the CE95352 Blinking LED.pdf from PSoC Creator.
Figure 5-8. Project Datasheet - CE95352 Blinking LED.pdf
5.3 **CE95277 ADC and UART**

This code example implements a simple data collection system using the DelSig ADC and the UART component. The ADC continuously samples an analog input. The resulting samples can be sent to a PC over a UART connection a single sample at a time or continuously. Emulated data, which is just an incrementing number, can also be sent over the UART connection to test the communication. The USB-UART Bridge in the KitProg is used to create an RS-232 connection to a terminal program on a PC. The terminal program is used to send commands to get the ADC sample data and read the resulting responses.

Figure 5-9. TopDesign CE95277 ADC and UART

<table>
<thead>
<tr>
<th>ADC Settings:</th>
<th>UART Settings:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sampling Mode: Continuous</td>
<td>Baud Rate: 115200</td>
</tr>
<tr>
<td>Resolution: 8 Bit</td>
<td>Date Bits: 8</td>
</tr>
<tr>
<td>Samples per Second: 10000</td>
<td>Parity: None</td>
</tr>
<tr>
<td>Input Range: Vssa to 6.144 V (0.0 to 6*Vref)</td>
<td>Stop Bits: 1</td>
</tr>
<tr>
<td>Reference: Internal 1.024 V</td>
<td>Flow Control: None</td>
</tr>
</tbody>
</table>

Test Setup and Procedure:

1) Plug CY8CKIT-059 into USB port of PC using the PCB USB connector.

2) Program the CE95277 project onto the CY8CKIT-059.

3) Connect positive terminal of ADC to a voltage source using P0[0].

4) The UART Rx and Tx signals are already connected to the KitProg via the target pins P12[6] and P12[7].

5) The KitProg automatically enumerates as a virtual COM port. You can find the virtual COM port number by going to Start -> Control Panel -> Device Manager in a Windows system. Connect to the COM port using a terminal emulator program. Once connected, use the command ‘c’ to get a single sample, ‘s’ to stream continuous samples, or ‘e’ to get emulated samples. Use ‘x’ to cancel streaming of samples.

For detailed operation, refer to the **CE95277 ADC and UART.pdf** from PSoC Creator.
5.4 CE95394 USB HID Mouse

This project demonstrates the use of the USBFS component to implement a HID mouse. Using the standard HID mouse descriptor, the PSoC enumerates as a mouse on the PC. Once the enumeration is complete the PSoC sends data about the relative movement of the mouse to the PC. A single button is also implemented in the project to emulate the left button, or button 1, on a standard mouse. You can hold down the button on the kit and watch the cursor highlight text or select items on a desktop while it draws the box.

Figure 5-10. CE95354 HID Mouse

USBFS Settings:
- Power: Bus Powered
- Class: HID
- HID Report: 3 Button Mouse

Test Setup and Procedure:

First program the CY8CKIT-059 with the CE95394 project using the following steps:

1) Connect the kit to a PC using the PCB USB connector.
2) Program the project onto the board.
3) Unplug the PCB USB connector.

Next test the project using the following steps:

1) Connect the CY8CKIT-059 to a PC via a USB cable plugged into the USB micro connector.
2) After enumeration observe the mouse cursor moving in a square pattern.
3) Press SW1 on the CY8CKIT-059 to emulate a left click on a mouse.

For detailed operation, refer to the CE95394 HID Mouse.pdf from PSoC Creator.
A. Appendix

A.1 PSoC 5LP Prototyping Kit Schematics
A.2 Programming PSoC 5LP Prototyping Kit Using MiniProg3/KitProg

The target board provides a provision to program the PSoC 5LP device using MiniProg3 or an external KitProg via the 5-pin SWD header or the 10-pin JTAG header. To do this, connect wires or a 5-pin 100-mil spaced header to J3 or a 10-pin JTAG header to J5 on the target board. The PSoC 5LP Prototyping Kit supports both power cycle and reset programming modes.

Figure A-1. Connecting CY8CKIT-059 to MiniProg3

Note: CY8CKIT-002 MiniProg3 is not part of the PSoC 5LP Prototyping Kit contents and can be purchased from the Cypress Online Store.
## A.3 Bill of Materials

<table>
<thead>
<tr>
<th>Item</th>
<th>Qty</th>
<th>Reference</th>
<th>Value</th>
<th>Description</th>
<th>Mfr Name</th>
<th>Mfr Part Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>N/A</td>
<td>N/A</td>
<td>PCB, 108.89mm x 24.13mm, High Tg, ENIG finish, 2 layer, Color = BLACK, Silk = WHITE</td>
<td>Cypress Semiconductor</td>
<td>600-60178-01</td>
</tr>
<tr>
<td>2</td>
<td>19</td>
<td>C1,C3,C5,C6,C10,C11,C14, C18,C20,C22,C23,C27,C29, C32,C33,C34,C35,C39,C40</td>
<td>0.1 uF</td>
<td>CAP .1UF 16V CERAMIC Y5V 0402</td>
<td>AVX Corporation</td>
<td>0402YG104ZAT2A</td>
</tr>
<tr>
<td>3</td>
<td>1</td>
<td>C4</td>
<td>2200 pF</td>
<td>CAP CER 2200PF 50V 5% NP0 0805</td>
<td>Murata Electronics</td>
<td>GRM2165C1H222JA01D</td>
</tr>
<tr>
<td>4</td>
<td>17</td>
<td>C7,C8,C9,C12,C13, C15,C16, C21,C24,C25,C26,C28,C30, C31,C36,C37,C38</td>
<td>1.0 uF</td>
<td>CAP CERAMIC 1.0UF 25V X5R 0603 10%</td>
<td>Taiyo Yuden</td>
<td>TMK107BJ105KA-T</td>
</tr>
<tr>
<td>5</td>
<td>1</td>
<td>C19</td>
<td>0.01 uF</td>
<td>CAP 10000PF 16V CERAMIC 0402 SMD</td>
<td>TDK Corporation</td>
<td>C1005X7R1C103K050BA</td>
</tr>
<tr>
<td>6</td>
<td>2</td>
<td>C41,C42</td>
<td>22 pF</td>
<td>CAP CER 22PF 50V 2% C0G 0402</td>
<td>TDK Corporation</td>
<td>C1005C0G1H220G050BA</td>
</tr>
<tr>
<td>7</td>
<td>2</td>
<td>D1,D2</td>
<td>DIOODE, SCHOTTKY, 20V, 0.5A, 400mW, SOD-123</td>
<td>Faichild Semiconductor</td>
<td>MBR0520L</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>2</td>
<td>F1,F2</td>
<td>PTC Resettable Fuse</td>
<td>FUSE, PTC Resettable, 0.50A, 16V, 1210, SMD</td>
<td>Bel Fuse Inc</td>
<td>0ZCH0050FF2G</td>
</tr>
<tr>
<td>9</td>
<td>1</td>
<td>J6</td>
<td>USB Micro-B</td>
<td>CONN RCPT STD MICRO USB TYPE B</td>
<td>FCI</td>
<td>10103594-0001LF</td>
</tr>
<tr>
<td>10</td>
<td>1</td>
<td>LED1</td>
<td>User LED BLUE</td>
<td>LED, BLUE, CLEAR, 0805, SMD</td>
<td>Lite-On Inc</td>
<td>LTST-C170TBKT</td>
</tr>
<tr>
<td>11</td>
<td>1</td>
<td>LED2</td>
<td>POWER LED Amber</td>
<td>LED 595NM AMB DIFF 0805 SMD</td>
<td>Avago Technologies US Inc.</td>
<td>HSMA-C170</td>
</tr>
<tr>
<td>12</td>
<td>1</td>
<td>LED3</td>
<td>Status LED Green</td>
<td>LED GREEN CLEAR 0805 SMD</td>
<td>Chicago Miniature/ Visual Communications Company-VCC</td>
<td>CMD17-21VGC/TR8</td>
</tr>
<tr>
<td>13</td>
<td>2</td>
<td>R2,R3</td>
<td>15K</td>
<td>RES SMD 15K OHM 5% 1/10W 0402</td>
<td>Panasonic - ECG</td>
<td>ERJ-2GEJ153X</td>
</tr>
<tr>
<td>14</td>
<td>4</td>
<td>R4,R6,R16,R17</td>
<td>22E</td>
<td>RES, 22 OHM, 1%, 100PPM, 1/16W, 0402</td>
<td>Panasonic - ECG</td>
<td>ERJ-2RKF22R0X</td>
</tr>
<tr>
<td>15</td>
<td>3</td>
<td>R5,R22,R23</td>
<td>ZERO</td>
<td>RES SMD 0.0 OHM JUMPER 0603 1/10W</td>
<td>Panasonic - ECG</td>
<td>ERJ-3GEY0R00V</td>
</tr>
<tr>
<td>16</td>
<td>2</td>
<td>R7,R9</td>
<td>2.2K</td>
<td>RES 2.2K OHM 1/10W 5% 0603 SMD</td>
<td>Panasonic-ECG</td>
<td>ERJ-3GEYJ222V</td>
</tr>
<tr>
<td>17</td>
<td>1</td>
<td>R10</td>
<td>560 ohm</td>
<td>RES, 560 OHM, 5%, 200PPM, 1/10W, 0603, SMD</td>
<td>Panasonic - ECG</td>
<td>ERJ-3GEYJ561V</td>
</tr>
<tr>
<td>18</td>
<td>1</td>
<td>R12</td>
<td>100K</td>
<td>RES 100K OHM 1/10W 5% 0402 SMD</td>
<td>Panasonic - ECG</td>
<td>ERJ-2GEJ104X</td>
</tr>
<tr>
<td>19</td>
<td>2</td>
<td>R13,R14</td>
<td>30K</td>
<td>RES SMD 30K OHM 5% 1/10W 0402</td>
<td>Panasonic - ECG</td>
<td>ERJ-2GEJ303X</td>
</tr>
<tr>
<td>Item</td>
<td>Qty</td>
<td>Reference</td>
<td>Value</td>
<td>Description</td>
<td>Mfr Name</td>
<td>Mfr Part Number</td>
</tr>
<tr>
<td>------</td>
<td>-----</td>
<td>-----------</td>
<td>-------</td>
<td>-------------</td>
<td>----------</td>
<td>----------------</td>
</tr>
<tr>
<td>20</td>
<td>4</td>
<td>R8,R11,R15,R20</td>
<td>ZERO</td>
<td>RES SMD 0.0 OHM JUMPER 1/8W 0805</td>
<td>Panasonic - ECG</td>
<td>ERJ-6GEY0R00V</td>
</tr>
<tr>
<td>21</td>
<td>2</td>
<td>R18,R21</td>
<td>820 ohm</td>
<td>RES, 820 OHM, 5%, 1/10W, 0603</td>
<td>Panasonic - ECG</td>
<td>ERJ-3GEYJ821V</td>
</tr>
<tr>
<td>22</td>
<td>2</td>
<td>SW1,SW3</td>
<td>Switch</td>
<td>SW, TACTILE SWITCH, SPST-NO, 0.05A, 32V</td>
<td>C&amp;K Components</td>
<td>KMR221GLFS</td>
</tr>
<tr>
<td>23</td>
<td>1</td>
<td>TVS1</td>
<td>TVS DIODE</td>
<td>TVS, 5V, 350W, SOD-332</td>
<td>Semtech</td>
<td>SD05.TCT</td>
</tr>
<tr>
<td>24</td>
<td>1</td>
<td>U1</td>
<td>CY8C5868LTI-LP039 QFN68</td>
<td>PSoc 5LP CYC58LP, 67 MHz</td>
<td>Cypress Semiconductor</td>
<td>CY8C5868LTI-LP039</td>
</tr>
<tr>
<td>25</td>
<td>1</td>
<td>U2</td>
<td>CY8C5888LTI-LP097 QFN68</td>
<td>PSoc 5LP CYC58LP, 80 MHz</td>
<td>Cypress Semiconductor</td>
<td>CY8C5888LTI-LP097</td>
</tr>
<tr>
<td>26</td>
<td>1</td>
<td>U3</td>
<td>NTZD3152P</td>
<td>FET DUAL P-CH 20V 430mA SOT-563</td>
<td>ON Semiconductor</td>
<td>NTZD3152PT1G</td>
</tr>
</tbody>
</table>

No Load Components

<table>
<thead>
<tr>
<th>Item</th>
<th>Qty</th>
<th>Reference</th>
<th>Value</th>
<th>Description</th>
<th>Mfr Name</th>
<th>Mfr Part Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>2</td>
<td>J1,J2</td>
<td>HDR 1x26</td>
<td>CONN HDR BRKWAY 26POS VERT 2.54mm, 15AU, TH</td>
<td>TE Connectivity</td>
<td>2-104427-4</td>
</tr>
<tr>
<td>3</td>
<td>2</td>
<td>J3,J7</td>
<td>HDR 1x5</td>
<td>CONN HEADER 5POS .100 VERT TIN</td>
<td>Molex</td>
<td>22-23-2051</td>
</tr>
<tr>
<td>4</td>
<td>1</td>
<td>J4</td>
<td>HDR 1x2</td>
<td>CONN HEADR BRKWAY .100 02POS STR</td>
<td>TE Connectivity</td>
<td>9-146280-0-02</td>
</tr>
<tr>
<td>5</td>
<td>1</td>
<td>J5</td>
<td>50MIL KEYED SMD</td>
<td>CONN, HEADER, MALE, 1.27mm, 10POS, GOLD, SMD</td>
<td>Samtec Inc</td>
<td>FTSH-105-01-L-DV-K</td>
</tr>
<tr>
<td>6</td>
<td>2</td>
<td>J8,J9</td>
<td>HDR 1x7</td>
<td>CONN HEADER FEMALE 7POS .1* GOLD</td>
<td>Sullins Connector Solutions</td>
<td>PPC071LFBN-RC</td>
</tr>
<tr>
<td>7</td>
<td>2</td>
<td>R1,R19</td>
<td>4.7K</td>
<td>RES SMD 4.7K OHM 5% 1/10W 0402</td>
<td>Panasonic - ECG</td>
<td>ERJ-2GEJ472X</td>
</tr>
<tr>
<td>8</td>
<td>1</td>
<td>SW2</td>
<td>SW PUSHBUTTON</td>
<td>SWITCH TACTILE SPST-NO 0.05A 12V</td>
<td>C&amp;K Components</td>
<td>PTS635SL50 LFS</td>
</tr>
<tr>
<td>9</td>
<td>3</td>
<td>TP1,TP2,TP3</td>
<td>BLACK</td>
<td>TP, TEST POINT, 0.040*D, BLACK, TH</td>
<td>Keystone Electronics</td>
<td>5000</td>
</tr>
<tr>
<td>10</td>
<td>1</td>
<td>Y1</td>
<td>BLACK</td>
<td>CRystal 32.768kHz 12.5PF THRU</td>
<td>Citizen Finetech Miyota</td>
<td>CFS308-32.768KDZF-UB</td>
</tr>
</tbody>
</table>

Label

<table>
<thead>
<tr>
<th>Item</th>
<th>Qty</th>
<th>Reference</th>
<th>Value</th>
<th>Description</th>
<th>Mfr Name</th>
<th>Mfr Part Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>38</td>
<td>1</td>
<td>N/A</td>
<td>N/A</td>
<td>LBL, PCA Label, Vendor Code, Datecode, Serial Number 121-60210-01 REV 01 (YYWWWVXXXXX)</td>
<td>Cypress Semiconductor</td>
<td>N/A</td>
</tr>
<tr>
<td>39</td>
<td>1</td>
<td>N/A</td>
<td>N/A</td>
<td>LBL, PCBA Anti-Static Warning, 10mm X 10mm</td>
<td>Cypress Semiconductor</td>
<td>N/A</td>
</tr>
</tbody>
</table>
## Revision History

### CY8CKIT-059 PSoC® 5LP Prototyping Kit Guide Revision History

<table>
<thead>
<tr>
<th>Revision</th>
<th>Issue Date</th>
<th>Origin of Change</th>
<th>Description of Change</th>
</tr>
</thead>
<tbody>
<tr>
<td>**</td>
<td>02/23/2015</td>
<td>PMAD</td>
<td>New kit guide</td>
</tr>
<tr>
<td>*A</td>
<td>04/02/2015</td>
<td>PMAD</td>
<td>Updated several sections of the Kit Guide. Added details about load capacitors for 32 kHz external crystal oscillator.</td>
</tr>
</tbody>
</table>